Share this page : facebooktwitterlinkedinmailfacebooktwitterlinkedinmail

apt-get update
apt-get –fix-missing

sudo gdebi package.deb

The package.deb is the name of the package you want to install

sudo apt-get -f install

The teamviewer in Kali:

 

Its not as simple as download and install or dpkg -i teamviewer.deb. Now with 32 bit systems a simple dpkg -i teamviewer.deb might suffice. By teamviewer.deb, i mean the full file name whatever it is, too lazy too copypaste it right now.

HOW TO TEAMVIEWER ON KALI LINUX
###############################
FIRST JUST JUST TRY THEN
========================
Download Teamviewer version 7 or 8 in the 64 bit for Ubuntu/debian, (i did because 64 bit because I have 64 bit machine)
# cd folderwheredownload
# dpkg -i teamviewer_linux_x64.deb
IF GET DEPENDENCY ISSUES
========================
First check your architecture
# uname -a
Linux kalikos 3.7-trunk-amd64 #1 SMP Debian 3.7.2-0+kali8 x86_64 GNU/Linux
Then check current architecture with dpkg
# dpkg –print-architecture
you should see amd64 (Thats because thats the flavor of kali I installed, they dont have an intel64 – remember amd64 is just 64 bit and it works for intel and amd… amd made 64 bit first and then intel adopted it as well – also my pcs “cat /proc/cpuinfo” shows this in case you are curious: model name : Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz)
For teamviewer install to work right we will need to add a foreign architecture
# dpkg –print-foreign-architectures
It should be empty, but if its not thats okay, just make sure you add i386 like this
# dpkg –add-architecture i386
Confirm its added with:
# dpkg –print-foreign-architectures
You should now see the i386
anyhow you might need to run dpkg -i teamviewer_linux_x64.dev again so that it tries to fix those same errors.
fix errors like this, they should download alot of things
# apt-get -f install <— note probably didnt need this, but I ran it like that oh well
# apt-get update
# apt-get -f install <— technically tou dont need to run this after but I did
Now running this will fix
# dpkg -i teamviewer_linux_x64.deb