Download the 3600 3700 images and install the NM-16ESW module, which contains 16 switch ports.
Step 1
Before making vlans, we need a make sure you have a flash disk created for the switch to store the “vlan.dat” file , or else, you will get an error message like:
% not enough space on flash to store vlan database. trying squeeze…
% error squezzing flash – (No device available)
Error on database apply 40: NV storage failure
Use ‘abort’ command to exit
You can create a flash disk in the way: go to ” Edit > Preferences > Dynamips > IOS routers > select the image you used for switch > edit> Memories and disks > Disks: PCMCIA disk0 size: “, give it a space like 128MB or 256MB.
Step 2 Configuration for Switch:
SW#vlan database
SW(vlan)#vlan 10 name office1
SW(vlan)#vlan 20 name office2
SW(vlan)#exit
SW(config-if)#interface vlan 10
SW(config-if)#ip address 10.1.1.1 255.255.255.0
SW(config-if)#no shu
SW(config-if)#interface vlan 20
SW(config-if)#ip address 20.1.1.1 255.255.255.0
SW(config-if)#exit
SW(config)#ip routing
SW(config-if)#interface f0/0
SW(config-if)#no shutdown
SW(config-if)# switchport mode access
SW(config-if)# switchport access vlan 10
SW(config-if)#interface f0/1
SW(config-if)#no shutdown
SW(config-if)#switchport mode access
SW(config-if)# switchport access vlan 20
Verify Vlan
show vlan-switch
equals show vlan
in a switch
Can not build connection between the switchport and a pc
The default duplex mode of the switchport is duplex auto, if you connect it to a PC, the link is up but protocol will be down.
Use interface mode command :
int range f 1/0 - 15
//note the space between 0 and hyphen.
Speed 100
Then
duplex full
command to fix it.