Configure multiarea OSPF
 4 steps to implementing multiarea OSPF:

Steps 1 and 2 are part of the planning process.

Step 1. Gather the network requirements and parameters – This includes determining the number of host and network devices, the IP addressing scheme (if already implemented), the size of the routing domain, the size of the routing tables, the risk of topology changes, and other network characteristics.

Step 2. Define the OSPF parameters – Based on information gathered during Step 1, the network administrator must determine if single-area or multiarea OSPF is the preferred implementation.
If multiarea OSPF is selected, there are several considerations the network administrator must take into account while determining the OSPF parameters, to include:

  • IP addressing plan – This governs how OSPF can be deployed and how well the OSPF deployment might scale. A detailed IP addressing plan, along with the IP subnetting information, must be created. A good IP addressing plan should enable the usage of OSPF multiarea design and summarization. This plan more easily scales the network, as well as optimizes OSPF behavior and the propagation of LSA.
  • OSPF areas – Dividing an OSPF network into areas decreases the LSDB size and limits the propagation of link-state updates when the topology changes. The routers that are to be ABRs and ASBRs must be identified, as are those that are to perform any summarization or redistribution.
  • Network topology – This consists of links that connect the network equipment and belong to different OSPF areas in a multiarea OSPF design. Network topology is important to determine primary and backup links. Primary and backup links are defined by the changing OSPF cost on interfaces. A detailed network topology plan should also be used to determine the different OSPF areas, ABR, and ASBR as well as summarization and redistribution points, if multiarea OSPF is used.

Step 3. Configure the multiarea OSPF implementation based on the parameters.

Step 4. Verify the multiarea OSPF implementation based on the parameters.

Configuration:

There are no special commands required to implement this multiarea OSPF network. A router simply becomes an ABR when it has two network statements in different areas.

IPv4 example: OSPFv2 Multiarea Topology

For R1:

R1(config)# router ospf 10

R1(config-router)# router-id 1.1.1.1

R1(config-router)# network 10.1.1.1 0.0.0.0 area 1

R1(config-router)# network 10.1.2.1 0.0.0.0 area 1

R1(config-router)# network 192.168.10.1 0.0.0.0 area 0

R1(config-router)# end

R1#

For R2:

R2(config)# router ospf 10

R2(config-router)# router-id 2.2.2.2

R2(config-router)# network 192.168.10.0 0.0.0.3 area 0

R2(config-router)# network 192.168.10.4 0.0.0.3 area 0

R2(config-router)# network 10.2.1.0 0.0.0.255 area 0

R2(config-router)# end

R2#

For R3:

R3(config)# router ospf 10

R3(config-router)# router-id 3.3.3.3

R3(config-router)# network 192.168.10.6 0.0.0.0 area 0

R3(config-router)# network 192.168.1.1 0.0.0.0 area 2

R3(config-router)# network 192.168.2.1 0.0.0.0 area 2

R3(config-router)# end

R3#

Note: The inverse wildcard masks used to configure R2 and R3 purposely differ to demonstrate the two alternatives to entering network statements. The method used for R3 is simpler because the wildcard mask is always 0.0.0.0 and does not need to be calculated.

 

IPv6 example:

Similar to IPv4:

R1(config)# ipv6 router ospf 10

R1(config-rtr)#router-id 1.1.1.1

R1(config-rtr)#exit

R1(config)#int g0/0

R1(config-if)# ipv6 ospf 10 area 1